SCVMM 2012 R2 – VLAN Information missing on the Network Adapter Configuration

Observed this issue last week. The VLAN ID in the Network Interface details inside the properties of a VM is not showing up as expected.

Here is the scenario.

SCVMM 2012 R2 with Windows Server 2012 R2 HyperV.

VMs are deployed and all works well. The Virtual Switch is configured as a Trunk and each VM needs to specify the VLAN ID. All well, However the VLAN ID of a VM is not getting displayed in the VMM console.

VLAN ID Missing on VM Properties

VLAN ID Missing on VM Properties

 

However, If we verify the VLAN ID of the same VM over this command let, its properly configured.

VLAN ID through command

VLAN ID through commandlet

 

Now lets try to change the VLAN ID through SCVMM Console.

VLAN ID Change through SCVMM

VLAN ID Change through SCVMM

I changed the VLAN ID to 66 and here is the confirmation of the job status.

Change VLAN through SCVMM - Job successful

Change VLAN through SCVMM – Job successful

 

After this change, I verified that the new VLAN got updated on the VM using the commandlet.

 

VLAN ID Change - Confirmation over Commandlet

VLAN ID Change – Confirmation over Commandlet

 

Going back to the SCVMM, The VM properties still don’t show that VLAN id is enabled and configured.

 VLAN-ID-CHANGE-Still-missing


VLAN ID CHANGE – Still missing

 

However, if we go to the connection details, VLAN ID is displayed.

VLAN ID Change - Connection details

VLAN ID Change – Connection details

 

This may be a minor bug. I have opened a case with the Microsoft support. I will update once I get more details on this.

 

Comments

comments

Comment ( 1 )

  1. SCVMM 2012 R2 – VLAN Information missing on the Network Adapter Configuration – Bug | Inside Virtualization - A dedicated blog on Virtualization

    […] mentioned on my earlier blog, the issue with missing VLAN is a BUG and we should wait for a fix through the upcoming […]